Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
index 7ede354..f7b0a47 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
@@ -1,10 +1,10 @@
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184"
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-
 DEPENDS += "systemd"
+SRCREV = "c3939dac2c060651361fc71516806f9ab8c38901"
+PV = "1.8.18+git${SRCPV}"
 
 SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https;branch=master"
-SRCREV = "c3939dac2c060651361fc71516806f9ab8c38901"
-
 # TODO: when a new company joins the OpenBMC project by signing
 #       a CLA, if they have an enterprise number on file with the
 #       IANA, the versioned file, $PWD/ipmitool/enterprise-numbers
@@ -18,8 +18,10 @@
     file://enterprise-numbers \
     "
 
-# make sure that the enterprise-numbers file gets installed in the root FS
-FILES:${PN} += "/usr/share/misc/enterprise-numbers"
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF:append = " --disable-ipmishell --enable-intf-dbus DEFAULT_INTF=dbus "
+
 do_compile:prepend() {
     # copy the SRC_URI version of enterprise-numbers
     # to the build dir to prevent a fetch
@@ -27,9 +29,5 @@
     cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers"
 }
 
-S = "${WORKDIR}/git"
-LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184"
-
-EXTRA_OECONF:append = " --disable-ipmishell --enable-intf-dbus DEFAULT_INTF=dbus "
-
-PV = "1.8.18+git${SRCPV}"
+# make sure that the enterprise-numbers file gets installed in the root FS
+FILES:${PN} += "/usr/share/misc/enterprise-numbers"