Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
index 8973eb2..e88c8cf 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -1,13 +1,8 @@
-HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
 SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
 DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
-PR = "r1"
-PV = "1.0+git${SRCPV}"
+HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-inherit meson pkgconfig systemd
-
 DEPENDS += " \
   phosphor-ipmi-blobs \
   phosphor-logging \
@@ -16,7 +11,7 @@
   ipmi-blob-tool \
   function2 \
 "
-
+SRCREV = "a4216a593f339dd4ce96bc7ad316b1100b6ab7a2"
 PACKAGECONFIG ?= "cleanup-delete"
 PACKAGECONFIG[cleanup-delete] = "-Dcleanup-delete=enabled,-Dcleanup-delete=disabled"
 # If using static-layout, reboot-update is a good option to handle updating.
@@ -24,12 +19,10 @@
 # Note that both reboot-update and update-status cannot be enabled at the same time.
 PACKAGECONFIG[reboot-update] = "-Dreboot-update=true,-Dreboot-update=false"
 PACKAGECONFIG[update-status] = "-Dupdate-status=true,-Dupdate-status=false"
-
 # Default options for supporting various flash types:
 PACKAGECONFIG[static-bmc] = "-Dupdate-type=static-layout,-Dupdate-type=none"
 PACKAGECONFIG[ubitar-bmc] = "-Dupdate-type=tarball-ubi,-Dupdate-type=none"
 PACKAGECONFIG[host-bios] = "-Dhost-bios=true,-Dhost-bios=false"
-
 # Hardware options to enable transmitting the data from the host.
 # Only one type of p2a or lpc can be enabled.
 PACKAGECONFIG[aspeed-p2a] = "-Dp2a-type=aspeed-p2a,,,,,aspeed-lpc nuvoton-lpc nuvoton-p2a-vga nuvoton-p2a-mbox"
@@ -38,33 +31,27 @@
 PACKAGECONFIG[nuvoton-p2a-vga] = "-Dp2a-type=nuvoton-p2a-vga,,,,,aspeed-p2a aspeed-lpc nuvoton-lpc nuvoton-p2a-mbox"
 PACKAGECONFIG[nuvoton-p2a-mbox] = "-Dp2a-type=nuvoton-p2a-mbox,,,,,aspeed-p2a aspeed-lpc nuvoton-lpc nuvoton-p2a-vga"
 PACKAGECONFIG[net-bridge] = "-Dnet-bridge=true,-Dnet-bridge=false"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
 
-EXTRA_OEMESON = "-Dtests=disabled -Dhost-tool=disabled"
-
-# Set this variable in your recipe to set it instead of using MAPPED_ADDRESS directly.
-IPMI_FLASH_BMC_ADDRESS ?= "0"
-EXTRA_OEMESON:append = " -Dmapped-address=${IPMI_FLASH_BMC_ADDRESS}"
+SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash;branch=master;protocol=https"
 
 S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash;branch=master;protocol=https"
-SRCREV = "a4216a593f339dd4ce96bc7ad316b1100b6ab7a2"
-
 SYSTEMD_PACKAGES = "${PN}"
 SYSTEMD_SERVICE:${PN} += " \
   phosphor-ipmi-flash-bmc-prepare.target \
   phosphor-ipmi-flash-bmc-verify.target \
   phosphor-ipmi-flash-bmc-update.target \
 "
-
-# If they enabled host-bios, add those three extra targets.
-HOST_BIOS_TARGETS = " \
-  phosphor-ipmi-flash-bios-prepare.target \
-  phosphor-ipmi-flash-bios-verify.target \
-  phosphor-ipmi-flash-bios-update.target \
-"
-
 SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'host-bios', '${HOST_BIOS_TARGETS}', '', d)}"
 
+inherit meson pkgconfig systemd
+
+EXTRA_OEMESON = "-Dtests=disabled -Dhost-tool=disabled"
+EXTRA_OEMESON:append = " -Dmapped-address=${IPMI_FLASH_BMC_ADDRESS}"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
 FILES:${PN}:append = " ${libdir}/ipmid-providers"
 FILES:${PN}:append = " ${libdir}/blob-ipmid"
 FILES:${PN}:append = " ${libdir}/tmpfiles.d"
@@ -74,4 +61,11 @@
 BLOBIPMI_PROVIDER_LIBRARY += "liblogblob.so"
 BLOBIPMI_PROVIDER_LIBRARY += "${@bb.utils.contains('PACKAGECONFIG', 'cleanup-delete', 'libfirmwarecleanupblob.so', '', d)}"
 
-do_configure[depends] += "virtual/kernel:do_shared_workdir"
+# Set this variable in your recipe to set it instead of using MAPPED_ADDRESS directly.
+IPMI_FLASH_BMC_ADDRESS ?= "0"
+# If they enabled host-bios, add those three extra targets.
+HOST_BIOS_TARGETS = " \
+  phosphor-ipmi-flash-bios-prepare.target \
+  phosphor-ipmi-flash-bios-verify.target \
+  phosphor-ipmi-flash-bios-update.target \
+"