Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-psu-software-manager_git.bb b/meta-phosphor/recipes-phosphor/power/phosphor-psu-software-manager_git.bb
index 8c171d6..f87f13a 100644
--- a/meta-phosphor/recipes-phosphor/power/phosphor-psu-software-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-psu-software-manager_git.bb
@@ -1,45 +1,28 @@
+# The below configs are expected to be overriden by machine layer
+SUMMARY = "Phosphor PSU software manager"
+DESCRIPTION = "Providing PSU firmware version and upgrade"
 HOMEPAGE = "https://github.com/openbmc/phosphor-psu-code-mgmt"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-SRC_URI += "git://github.com/openbmc/phosphor-psu-code-mgmt;branch=master;protocol=https"
-SRCREV = "97092314b107744e290b3fd6cf0eeef43247400c"
-SUMMARY = "Phosphor PSU software manager"
-DESCRIPTION = "Providing PSU firmware version and upgrade"
-
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
-inherit meson
-inherit pkgconfig
-inherit obmc-phosphor-systemd
-
-S = "${WORKDIR}/git"
-
 DEPENDS = " \
          phosphor-logging \
          phosphor-dbus-interfaces \
          sdbusplus \
          openssl \
          "
+SRCREV = "97092314b107744e290b3fd6cf0eeef43247400c"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
 
-# The default config of this repo depends on utils from phosphor-power.
-# If your system does not depend on phosphor-power, please use
-# RDEPENDS:${PN}:remove to remove the dependency.
-RDEPENDS:${PN} += "phosphor-power"
+SRC_URI += "git://github.com/openbmc/phosphor-psu-code-mgmt;branch=master;protocol=https"
 
-# The below configs are expected to be overriden by machine layer
+S = "${WORKDIR}/git"
+SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.Software.Psu.Updater.service"
+SYSTEMD_SERVICE:${PN} += "psu-update@.service"
 
-## The psutils here comes from phosphor-power repo where
-## * PSU_VERSION_UTIL accepts a PSU inventory path and returns the PSU
-##   firmware version string
-## * PSU_VERSION_COMPARE_UTIL accepts several PSU inventory paths and return
-##   the newest version string
-PSU_VERSION_UTIL ?= "-DPSU_VERSION_UTIL='/usr/bin/psutils --raw --get-version'"
-PSU_VERSION_COMPARE_UTIL ?= "-DPSU_VERSION_COMPARE_UTIL='/usr/bin/psutils --raw --compare'"
-
-## The psu-update@.service from repo is an example service that only prints a log and fails
-## Override it in a machine layer to invoke the psu update util
-PSU_UPDATE_SERVICE ?= "-DPSU_UPDATE_SERVICE=psu-update@.service"
+inherit meson
+inherit pkgconfig
+inherit obmc-phosphor-systemd
 
 EXTRA_OEMESON = " \
         -Dtests=disabled \
@@ -48,5 +31,18 @@
         ${PSU_UPDATE_SERVICE} \
         "
 
-SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.Software.Psu.Updater.service"
-SYSTEMD_SERVICE:${PN} += "psu-update@.service"
+# The default config of this repo depends on utils from phosphor-power.
+# If your system does not depend on phosphor-power, please use
+# RDEPENDS:${PN}:remove to remove the dependency.
+RDEPENDS:${PN} += "phosphor-power"
+
+## The psutils here comes from phosphor-power repo where
+## * PSU_VERSION_UTIL accepts a PSU inventory path and returns the PSU
+##   firmware version string
+## * PSU_VERSION_COMPARE_UTIL accepts several PSU inventory paths and return
+##   the newest version string
+PSU_VERSION_UTIL ?= "-DPSU_VERSION_UTIL='/usr/bin/psutils --raw --get-version'"
+PSU_VERSION_COMPARE_UTIL ?= "-DPSU_VERSION_COMPARE_UTIL='/usr/bin/psutils --raw --compare'"
+## The psu-update@.service from repo is an example service that only prints a log and fails
+## Override it in a machine layer to invoke the psu update util
+PSU_UPDATE_SERVICE ?= "-DPSU_UPDATE_SERVICE=psu-update@.service"