Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
index 77a2537..54c5991 100644
--- a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
+++ b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
@@ -1,18 +1,28 @@
 SUMMARY = "OpenBMC gdbus library"
 DESCRIPTION = "libopenbmc_intf provides a set of gpio access \
 methods and the GDBUS skeleton code for the org.openbmc DBUS API."
-PR = "r1"
+DEPENDS += "glib-2.0"
+DEPENDS += "cjson"
 PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "file://gpio_defs.json"
+
+SKELETON_DIR = "libopenbmc_intf"
 
 inherit skeleton
 inherit pkgconfig
 
-DEPENDS += "glib-2.0"
-DEPENDS += "cjson"
+do_install() {
+        oe_runmake install DESTDIR=${D}
+        install -d ${D}${sysconfdir}/default/obmc/gpio/
+        install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
+}
 
-SKELETON_DIR = "libopenbmc_intf"
-
-SRC_URI += "file://gpio_defs.json"
+# Ensure the library is not in the dev package
+FILES_SOLIBSDEV = ""
+# Now add the link to the production package
+FILES:${PN} += "${libdir}/libopenbmc_intf.so"
 
 # Users of libopenbmc_intf use custom makefiles that do not
 # support the proper library version detection and linking.
@@ -21,16 +31,3 @@
 # This next line tells bitbake to skip the check which
 # ensures no links are put in the rootfs
 INSANE_SKIP:${PN} += "dev-so"
-
-# Ensure the library is not in the dev package
-FILES_SOLIBSDEV = ""
-
-# Now add the link to the production package
-FILES:${PN} += "${libdir}/libopenbmc_intf.so"
-
-do_install() {
-        oe_runmake install DESTDIR=${D}
-
-        install -d ${D}${sysconfdir}/default/obmc/gpio/
-        install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
-}