Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb b/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb
index 34e1e5d..999d86c 100644
--- a/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb
+++ b/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb
@@ -1,16 +1,8 @@
-HOMEPAGE = "http://github.com/openbmc/smbios-mdr"
 SUMMARY = "Extract CPU and Memory Inventory from SMSMBIOS Table and PECI"
 DESCRIPTION = "This package parses SMBIOS tables, reads Intel CPU PIROM and PECI and provides a dedicated IPMI blob to receive SMBIOS tables sent from LinuxBoot"
-
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
+HOMEPAGE = "http://github.com/openbmc/smbios-mdr"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-inherit cmake pkgconfig systemd
-inherit obmc-phosphor-ipmiprovider-symlink
-
 DEPENDS += " \
     boost \
     systemd \
@@ -18,22 +10,27 @@
     phosphor-dbus-interfaces \
     phosphor-logging \
     "
-
+SRCREV = "b492838a92351ecae20a80c9f3c176507f6f72f4"
 PACKAGECONFIG ?= "cpuinfo"
 PACKAGECONFIG[smbios-no-dimm] = "-DDIMM_DBUS=OFF,-DDIMM_DBUS=ON"
 PACKAGECONFIG[cpuinfo] = "-DCPU_INFO=ON,-DCPU_INFO=OFF,libpeci i2c-tools"
 PACKAGECONFIG[smbios-ipmi-blob] = "-DIPMI_BLOB=ON,-DIPMI_BLOB=OFF,phosphor-ipmi-blobs"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
 
-EXTRA_OECMAKE = "-DYOCTO=ON"
+SRC_URI = "git://github.com/openbmc/smbios-mdr.git;branch=master;protocol=https"
 
 S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/smbios-mdr.git;branch=master;protocol=https"
-SRCREV = "b492838a92351ecae20a80c9f3c176507f6f72f4"
-
 SYSTEMD_SERVICE:${PN} += "smbios-mdrv2.service"
 SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'cpuinfo', 'xyz.openbmc_project.cpuinfo.service', '', d)}"
 
+inherit cmake pkgconfig systemd
+inherit obmc-phosphor-ipmiprovider-symlink
+
+EXTRA_OECMAKE = "-DYOCTO=ON"
+
 FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
 FILES:${PN}:append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
-FILES:${PN}-dev:append  = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
+FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
+
 BLOBIPMI_PROVIDER_LIBRARY += "${@bb.utils.contains('PACKAGECONFIG', 'smbios-ipmi-blob', 'libsmbiosstore.so', '', d)}"