Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
index ee0a386..2678e60 100644
--- a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
@@ -1,16 +1,3 @@
-# This recipe requires online access to build, as it uses NPM for dependency
-# management and resolution.
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-SRC_URI = "git://github.com/openbmc/webui-vue.git;branch=master;protocol=https"
-SRCREV = "d9566225f1c25b1892c332e0f3a16c1b5e4ba714"
-S = "${WORKDIR}/git"
-
-DEPENDS:prepend = "nodejs-native "
-
 # allarch is required because the files this recipe produces (html and
 # javascript) are valid for any target, regardless of architecture.  The allarch
 # class removes your compiler definitions, as it assumes that anything that
@@ -19,31 +6,39 @@
 # build the library that it then uses to compress the scss into normal css.
 # Enabling allarch, then re-adding the compiler flags was the best of the bad
 # options
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+DEPENDS:prepend = "nodejs-native "
+SRCREV = "d9566225f1c25b1892c332e0f3a16c1b5e4ba714"
+PV = "1.0+git${SRCPV}"
+# This recipe requires online access to build, as it uses NPM for dependency
+# management and resolution.
+PR = "r1"
+
+SRC_URI = "git://github.com/openbmc/webui-vue.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
 
 inherit allarch
 
+EXTRA_OENPM ?= ""
+
 export CXX = "${BUILD_CXX}"
 export CC = "${BUILD_CC}"
 export CFLAGS = "${BUILD_CFLAGS}"
 export CPPFLAGS = "${BUILD_CPPFLAGS}"
 export CXXFLAGS = "${BUILD_CXXFLAGS}"
 
-FILES:${PN} += "${datadir}/www/*"
-
-EXTRA_OENPM ?= ""
-
-# Workaround 
+# Workaround
 # Network access from task are disabled by default on Yocto 3.5
 # https://git.yoctoproject.org/poky/tree/documentation/migration-guides/migration-3.5.rst#n25
 do_compile[network] = "1"
-
 do_compile () {
     cd ${S}
     rm -rf node_modules
     npm --loglevel info --proxy=${http_proxy} --https-proxy=${https_proxy} install
     npm run build ${EXTRA_OENPM}
 }
-
 do_install () {
    # create directory structure
    install -d ${D}${datadir}/www
@@ -52,3 +47,4 @@
    find ${D}${datadir}/www -type d -exec chmod a=rx,u+w '{}' +
 }
 
+FILES:${PN} += "${datadir}/www/*"