Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
index 19974e7..c5fda1b 100644
--- a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
+++ b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
@@ -1,20 +1,17 @@
 SUMMARY = "PECI PCIe"
 DESCRIPTION = "Gathers PCIe information using PECI \
 and provides it on D-Bus"
-
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
-inherit cmake pkgconfig systemd
+DEPENDS = "boost sdbusplus libpeci"
+SRCREV = "be1fdbfddb8f753132e781109e72b5f2c64140a2"
+PV = "0.1+git${SRCPV}"
 
 SRC_URI = "git://github.com/openbmc/peci-pcie;branch=master;protocol=https"
 
-DEPENDS = "boost sdbusplus libpeci"
-
-PV = "0.1+git${SRCPV}"
-SRCREV = "be1fdbfddb8f753132e781109e72b5f2c64140a2"
-
 S = "${WORKDIR}/git"
-
 SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.PCIe.service"
 
+inherit cmake pkgconfig systemd
+
 EXTRA_OECMAKE = "-DYOCTO=1"