meta-openembedded: subtree update:e4ac09169d..459dbf1078

Alex Kiernan (1):
      leveldb: Upgrade 1.20 -> 1.22

Cengiz Can (1):
      recipes-support: gperftools: RDEPENDS for pprof

Changqing Li (2):
      python3-django: upgrade 1.11.14 -> 2.2.7
      python-sqlparse/python3-sqlparse: move from meta-cloud-services

Christopher Larson (1):
      kconfig-frontends: drop unneeded target flex/bison deps

Daniels Umanovskis (1):
      gattlib: add recipe

Fabio Berton (3):
      mdbus2: Add recipe
      jpnevulator: Add recipe
      emlog: Add recipe

Jacopo Dall'Aglio (1):
      python-netifaces: add recipes

Khem Raj (8):
      packagegroup-meta-oe: Drop gperftools for mips/musl as well
      python-slip-dbus: Add missing rdep on six module
      htop: Use python3
      pidgin: Use python3
      mercurial: Upgrade to 5.2 and switch to py3
      a2jmidid: Upgrade to release 9
      pidgin: Use python3 during build
      tvheadend: Demand use of py3 during build

Lei YU (1):
      googletest: Add PV and set to 1.10.0

Leon Anavi (1):
      stalonetray: Add a simple stand-alone system tray

Li Zhou (1):
      libssh2: Security Advisory - libssh2 - CVE-2019-17498

Michael Haener (1):
      libmbim: upgrade 1.20.0 -> 1.20.2

Nicola Lunghi (2):
      python-configargparse: add package (version 0.15.1)
      python3-dbussy: add recipe (v1.2.1)

Qi.Chen@windriver.com (1):
      python3-pid: upgrade to 2.2.5

Ross Burton (3):
      glmark2: upgrade to latest HEAD
      glmark2: use Python 3 to build
      jack: upgrade to 1.19.14

Ulrich Ölmann (1):
      python3-yarl: add missing dependencies

Zang Ruochen (6):
      p910nd: upgrade 0.95 -> 0.97
      links: upgrade 2.16 -> 2.20.2
      links-x11: upgrade 2.16 -> 2.20.2
      libmicrohttpd: upgrade 0.9.67 -> 0.9.68
      gsoap: upgrade 2.8.51 -> 2.8.95
      mksh: upgrade 56 -> 57

Zheng Ruoqin (1):
      libsdl: Refresh patch

zhangxiao (1):
      syslog-ng: Fix multilib header conflict - syslog-ng-config.h

Change-Id: I8557e00b893b61c10ee305fb3229db773b4b894f
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-devtools/mercurial/mercurial_5.2.bb b/meta-openembedded/meta-oe/recipes-devtools/mercurial/mercurial_5.2.bb
new file mode 100644
index 0000000..0fec4d1
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/mercurial/mercurial_5.2.bb
@@ -0,0 +1,35 @@
+SUMMARY = "The Mercurial distributed SCM"
+HOMEPAGE = "http://mercurial.selenic.com/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "python3 python3-native"
+RDEPENDS_${PN} = "python3 python3-modules"
+
+inherit python3native
+
+SRC_URI = "https://www.mercurial-scm.org/release/${BP}.tar.gz"
+SRC_URI[md5sum] = "9ba9d59157c002db8d8cab680de08eb5"
+SRC_URI[sha256sum] = "ff030e923f03ee15c91191996fcb099bfcfa60c7df263be227f67b6a65d36194"
+
+S = "${WORKDIR}/mercurial-${PV}"
+
+BBCLASSEXTEND = "native"
+
+export LDSHARED="${CCLD} -shared"
+
+EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
+    PREFIX=${prefix}"
+
+do_configure_append () {
+    sed -i -e 's:PYTHON?=python:PYTHON=python3:g' ${S}/Makefile
+}
+
+do_install () {
+    oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix}
+    sed -i -e 's:${STAGING_BINDIR_NATIVE}/python3-native/python3:${USRBINPATH}/env python3:g' ${D}${bindir}/hg
+}
+
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
+