meta-hpe: Add time sync on boot and use x86-power-control

Add a post boot command to sync time
Use x86-power-control for chassis host power management

Signed-off-by: Mike Garrett <mike.garrett@hpe.com>
Change-Id: I2f52cfc15eab4f2a63434e44b4e0c8f7d8eb0393
diff --git a/meta-hpe/classes/hpe-rootfs-postcommands.bbclass b/meta-hpe/classes/hpe-rootfs-postcommands.bbclass
new file mode 100644
index 0000000..6980c23
--- /dev/null
+++ b/meta-hpe/classes/hpe-rootfs-postcommands.bbclass
@@ -0,0 +1,7 @@
+touch_var_lib_systemd_clock() {
+	install -d ${IMAGE_ROOTFS}/var/lib/systemd/timesync/
+	touch ${IMAGE_ROOTFS}/var/lib/systemd/timesync/clock
+}
+
+ROOTFS_POSTPROCESS_COMMAND += '${@bb.utils.contains("DISTRO_FEATURES", "systemd", "touch_var_lib_systemd_clock; ", "", d)}'
+