meta-phosphor: config-in-skeleton.bbclass: drop inherit license

Drop inheriting license from obmc-phosphor-license.  The LICENSE value
is now provided by skeleton-rev, which also provides the SRC_URI.

(From meta-phosphor rev: 8861866cc9e34d74d4a07166b0787890ff43d0ae)

Change-Id: I20554471036568bec5bd2cf2fa8d6726e96e14e7
Signed-off-by: Patrick Venture <venture@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/classes/config-in-skeleton.bbclass b/meta-phosphor/classes/config-in-skeleton.bbclass
index 95c2d64..da49d61 100644
--- a/meta-phosphor/classes/config-in-skeleton.bbclass
+++ b/meta-phosphor/classes/config-in-skeleton.bbclass
@@ -5,7 +5,6 @@
 inherit setuptools
 inherit pythonnative
 inherit skeleton-rev
-inherit obmc-phosphor-license
 
 HOMEPAGE = "http://github.com/openbmc/skeleton"
 
@@ -13,8 +12,8 @@
 RPROVIDES_${PN} += "virtual-obmc-inventory-data"
 
 DEPENDS += "python"
-SRC_URI += "${SKELETON_URI};subpath=configs"
-S = "${WORKDIR}/configs"
+SRC_URI += "${SKELETON_URI};"
+S = "${WORKDIR}/git/configs"
 
 python() {
 	machine = d.getVar('MACHINE', True).capitalize() + '.py'