blob: a6d5007069325a3931ba0498b689b7e6e6abb3ba [file] [log] [blame]
DESCRIPTION = "Modern password hashing for your software and your servers."
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
DEPENDS += "${PYTHON_PN}-cffi-native"
SRC_URI[md5sum] = "fe31390dab603728f756cd3d6830c80a"
SRC_URI[sha256sum] = "5b93c1726e50a93a033c36e5ca7fdcd29a5c7395af50a6892f5d9e7c6cfbfb29"
inherit pypi setuptools3 ptest
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
RDEPENDS:${PN}:class-target += "\
${PYTHON_PN}-cffi \
${PYTHON_PN}-ctypes \
${PYTHON_PN}-shell \
${PYTHON_PN}-six \
"