blob: 119342a4bd7f3b51283bcde7d505d50ea54cb302 [file] [log] [blame]
SUMMARY = "World timezone definitions, modern and historical"
HOMEPAGE = "http://pythonhosted.org/pytz"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
inherit pypi setuptools3 ptest
SRC_URI[sha256sum] = "acad2d8b20a1af07d4e4c9d2e9285c5ed9104354062f275f3fcd88dcef4f1326"
RDEPENDS:${PN}:class-target += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-doctest \
${PYTHON_PN}-io \
${PYTHON_PN}-pickle \
${PYTHON_PN}-pprint \
${PYTHON_PN}-threading \
"
BBCLASSEXTEND = "native nativesdk"
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/pytz
install -d ${D}${PTEST_PATH}/pytz/tests
cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
cp -f ${S}/README.rst ${D}${PTEST_PATH}/
}