blob: 68f3f64295138ba94e2a65158f893f6bddb25d17 [file] [log] [blame]
SUMMARY = "Sensors plugin for the Xfce Panel"
HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=b94789bed9aec03b9656a9cc5398c706"
inherit xfce-panel-plugin
SRC_URI[sha256sum] = "da90f12e6ae995bcd1c81be35479a7a9d32308c65ecd64e568ba8c9592d39fcb"
SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch"
EXTRA_OECONF = " \
--disable-procacpi \
--disable-xnvctrl \
"
do_configure:prepend() {
sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
}
PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"
PACKAGECONFIG[libnotify] = "--enable-notification,--disable-notification, libnotify"
FILES_SOLIBSDEV = "${libdir}/xfce4/modules/lib*${SOLIBSDEV}"