blob: ae91d980fe5614a5afcf20b0d847d9b586634e52 [file] [log] [blame]
SUMMARY = "Software Construction tool (make/autotools replacement)"
HOMEPAGE = "https://github.com/SCons/scons"
SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d903b0b8027f461402bac9b5169b36f7"
SRC_URI += " file://0001-Fix-man-page-installation.patch"
SRC_URI[sha256sum] = "d47081587e3675cc168f1f54f0d74a69b328a2fc90ec4feb85f728677419b879"
PYPI_PACKAGE = "SCons"
inherit pypi setuptools3
RDEPENDS:${PN}:class-target = "\
python3-core \
python3-compression \
python3-fcntl \
python3-importlib-metadata \
python3-io \
python3-json \
python3-shell \
python3-pickle \
python3-pkg-resources \
python3-pprint \
"
do_install:append() {
install -d ${D}${mandir}/man1
mv ${D}${prefix}/scons*.1 ${D}${mandir}/man1/
}
do_install:append:class-native() {
create_wrapper ${D}${bindir}/scons SCONS_LIB_DIR='${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}' PYTHONNOUSERSITE='1'
}
BBCLASSEXTEND = "native"