meta-ibm: fans: Create machine-specific structure

Yocto automatically adds files/<MACHINE>/ to the file path, take
advantage of this feature to simplify the recipe and directory
structure.

Tested: Built witherspoon, witherspoon-128, and swift, and verified
        they all had the correct fans files in their image.

(From meta-ibm rev: 1c8b9d845092ccb6440fc9241993ac3d4db9c2d6)

Change-Id: I2dfa0b04dfba68311d67af10ccfa979f733e630f
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 9942eca..bc6ea80 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -1,6 +1,4 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-# Machine specific files override shared files with the same name
-FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}-${PN}:"
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
 
 # Package configuration
 FAN_PACKAGES += " \