Add recipe for Phosphor Debug collector

Resolves openbmc/openbmc#1503

Change-Id: Id42d8c5042af4a9a74a9a284f3601989a65c5054
Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
new file mode 100644
index 0000000..0c0c125
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Phosphor Debug Collector"
+DESCRIPTION = "Phosphor Debug Collector provides mechanisms \
+to collect various FFDC files and system parameters. \
+This will be helpful for troubleshooting the problems in OpenBMC \
+based systems."
+
+PR = "r1"
+
+inherit autotools \
+        pkgconfig \
+        obmc-phosphor-dbus-service
+
+require phosphor-debug-collector.inc
+
+DEPENDS += " \
+        phosphor-dbus-interfaces \
+        phosphor-dbus-interfaces-native \
+        phosphor-logging \
+        sdbusplus \
+        sdbusplus-native \
+        autoconf-archive-native \
+        "
+
+RDEPENDS_${PN} += " \
+        sdbusplus \
+        phosphor-dbus-interfaces \
+        phosphor-logging \
+        "
+
+DBUS_SERVICE_${PN} += "xyz.openbmc_project.Dump.service"
+
+S = "${WORKDIR}/git"