sdeventplus: Add package

This adds the initial recipe for the sdeventplus package.

Tested:
    Package builds successfully and the output looks correct.

Change-Id: I506955205dc9bcfe75a83b76442f4857c74b99bb
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-phosphor/common/recipes-extended/sdeventplus/sdeventplus_git.bb b/meta-phosphor/common/recipes-extended/sdeventplus/sdeventplus_git.bb
new file mode 100644
index 0000000..8f764a8
--- /dev/null
+++ b/meta-phosphor/common/recipes-extended/sdeventplus/sdeventplus_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "C++ bindings for systemd event APIs"
+DESCRIPTION = "C++ bindings for systemd event APIs."
+HOMEPAGE = "http://github.com/openbmc/sdeventplus"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+
+DEPENDS += " \
+        autoconf-archive-native \
+        systemd \
+        "
+
+EXTRA_OECONF_append += " \
+        --disable-examples \
+        --disable-tests \
+        "
+
+SRC_URI += "git://github.com/openbmc/sdeventplus"
+SRCREV = "cf1f4f97855c0ef44fc7d7118faaea2d0a9de946"
+
+S = "${WORKDIR}/git"