python-autotools: add DEPEND=python

This class is used for installing python-based packages,
using python.  So the packages need both python-native and
python.  Without this, there is a race condition in the SDK
that can cause the package install to be attempted before
python itself is installed.

Change-Id: Iab1cf149d715e3d68ecb580c5f107d6534b0b484
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass b/meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass
index 5a8e1e2..d69eb34 100644
--- a/meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass
@@ -1,6 +1,8 @@
 inherit obmc-phosphor-utils
 inherit pythonnative
 
+DEPENDS += "python"
+
 export BUILD_SYS
 export HOST_SYS
 export STAGING_INCDIR