meta-raspberrypi: subtree update:e2c1992955..cc6074c660

Andrei Gherzan (1):
      sdcard_image-rpi.bbclass: Fix when RPI_SDIMG_EXTRA_DEPENDS not defined

Christopher Clark (2):
      sdcard_image-rpi.bbclass: enable extensible inclusion into boot
      docs/extra-build-config.md: document vars to add to boot partition

Fabio Berton (1):
      u-boot: Move fw_env.config to u-boot append

Jakub Luzny (2):
      rpi-config: Add CAN_OSCILLATOR variable to set mcp2515 crystal frequency
      docs/extra-build-config.md: Document CAN_OSCILLATOR variable

Jeff Ithier (1):
      Generalize the naming of the bootfiles deploy directory

Martin Jansa (1):
      linux-raspberrypi-5.4: bump SRCREV to latest to fix perf build

Pierre-Jean Texier (3):
      rpi-default-versions: Switch defaults to 5.4
      raspberrypi-firmware: update to current HEAD
      linux-raspberrypi: bump to revision 4b945d5

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I50eca26a801bfe014d3cea271f0cb91e7b653445
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
index 9ce6425..7f38adb 100644
--- a/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/meta-raspberrypi/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append_rpi = " \
+    file://fw_env.config \
+"
+
 DEPENDS_append_rpi = " u-boot-default-script"
+
+do_install_append_rpi () {
+    install -d ${D}${sysconfdir}
+    install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}