meta-nuvoton: npcm7xx-bootblock: upgrade to 10.10.16

Changelog from 10.10.09:
 * MC: Enhanced training optimization.
 * SPI0 frequency is now only limited to be up to 50MHz (remove 40MHz
lower limit). This check is only performed if PLLs are changes (RUN_BMC
or new header frequency values).
 * Fix an issue in INTCR3 settings (FIU_FIX field).
 * MC: in enhanced training: change the sweep range accrording to the
location of the step. (run time optimization)

(From meta-nuvoton rev: e7db9495062eab77a319e6eb322cdfe0f68719d8)

Change-Id: I65a512a0110b183c5d9307aea1380cc914236d7d
Signed-off-by: Benjamin Fair <benjaminfair@google.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.16.bb b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.16.bb
new file mode 100644
index 0000000..77285dc
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.10.16.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Primary bootloader for NPCM7XX (Poleg) devices"
+DESCRIPTION = "Primary bootloader for NPCM7XX (Poleg) devices"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm7xx-bootblock"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+FILENAME = "Poleg_bootblock_${PV}.bin"
+
+S = "${WORKDIR}"
+
+SRC_URI = " \
+    https://raw.githubusercontent.com/Nuvoton-Israel/bootblock/${SRCREV}/LICENSE;name=lic \
+    https://github.com/Nuvoton-Israel/bootblock/releases/download/BootBlock_${PV}/Poleg_bootblock_basic.bin;downloadfilename=${FILENAME};name=bin \
+"
+
+SRC_URI[lic.md5sum] = "b234ee4d69f5fce4486a80fdaf4a4263"
+SRC_URI[bin.sha256sum] = "b2df56cc8667227fa625f11c628bfc10c831d36d076bf28ff376902d06b63a54"
+
+inherit deploy
+
+do_deploy () {
+	install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/Poleg_bootblock.bin
+}
+
+addtask deploy before do_build after do_compile