leds: rainier: Enable PACKAGECONFIG to use json

This enables phosphor-ledmanager to use JSON configuration file

Change-Id: I3cbd0bf6b60e81f9f0a479ad51dab438c708c6c1
Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
diff --git a/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend b/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
index 6121395..325d8bf 100644
--- a/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
@@ -5,6 +5,9 @@
 # Copies config file having arguments for led-set-all-groups-asserted.sh
 SYSTEMD_ENVIRONMENT_FILE_${PN}-ledmanager_append_rainier +="obmc/led/set-all/groups/config"
 
+# Use the JSON configuration file at runtime than the static led.yaml
+PACKAGECONFIG_append_rainier = " use-json"
+
 pkg_postinst_${PN}-ledmanager_rainier () {
 
     # Needed this to run as part of BMC boot