meta-security: subtree update:ab239f1497..46f7e7acbe

Armin Kuster (18):
      python3-scapy: update to 2.4.5
      lkrg-module: update 0.9.1
      packagegroup-core-security: exclude ossec-hids from musl
      ossec-hids: musl not compatable
      sssd: update to 2.5.0
      busybox: drop as libsecomp is in core
      linux-%_5.%.bbappend: drop recipe
      initramfs-framework: fix YCL issue.
      python3-scapy: drop , now in meta-python
      packagegroup-core-security: drop python3-scapy
      meta-hardening/initscripts: missed overide.
      meta-security: add sanity check
      meta-security/recipe-kernel: use sanity check
      linux-yocto-dev: drop bbappend
      meta-tpm: add layer sanity check
      meta-tpm/linux-yocto: use sanity support
      meta-integrity: add sanity check
      meta-integrity/recipe-kernel: use sanity check

Federico Pellegrin (1):
      aircrack-ng: update to 1.6

Kai Kang (2):
      sssd: set pid path with /run
      sssd: add fix-ldblibdir.patch back

Ricardo Salveti (1):
      tpm2-tss: fix usrmerge udev install path

Robert P. J. Day (1):
      Correct "securiyt" typo in maintainers.inc

Sekine Shigeki (1):
      smack: add 3 cves to allowlist

Upgrade Helper (2):
      clamav: upgrade to latest revision
      opendnssec: upgrade 2.1.8 -> 2.1.9

Yi Zhao (1):
      libgssglue: update SRC_URI

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I3bcabc218b240681d525111d16f963eb9b33c922
diff --git a/meta-security/recipes-security/aircrack-ng/aircrack-ng_1.6.bb b/meta-security/recipes-security/aircrack-ng/aircrack-ng_1.6.bb
new file mode 100644
index 0000000..8d3b531
--- /dev/null
+++ b/meta-security/recipes-security/aircrack-ng/aircrack-ng_1.6.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Aircrack-ng is a set of tools for auditing wireless networks"
+DESCRIPTION = "Aircrack-ng is an 802.11 WEP and WPA-PSK keys cracking program that can recover keys once enough data packets have been captured. It implements the standard FMS attack along with some optimizations like KoreK attacks, as well as the PTW attack, thus making the attack much faster compared to other WEP cracking tools."
+SECTION = "security"
+LICENSE = "GPL-2.0"
+
+LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=2;md5=1fbd81241fe252ec0f5658a521ab7dd8"
+
+DEPENDS = "libnl openssl sqlite3 libpcre libpcap"
+
+SRC_URI = "http://download.aircrack-ng.org/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "22ddc85549b51ed0da0931d01ef215e5"
+SRC_URI[sha256sum] = "4f0bfd486efc6ea7229f7fbc54340ff8b2094a0d73e9f617e0a39f878999a247"
+
+inherit autotools-brokensep pkgconfig
+
+PACKAGECONFIG ?= ""
+CFLAGS += " -I${S}/src/include"
+
+OEMAKE_EXTRA = "sqlite=true experimental=true pcre=true \
+                prefix=${prefix} \
+                "
+
+do_compile () {
+    make ${OEMAKE_EXTRA} TOOL_PREFIX=${TARGET_SYS}-
+}
+
+do_install () {
+    make DESTDIR=${D} ${OEMAKE_EXTRA} ext_scripts=true install
+}
+
+FILES_${PN} += "${libdir}/*.so"
+FILES_SOLIBSDEV = ""
+INSANE_SKIP_${PN} += "dev-so"
+
+RDEPENDS_${PN} = "libpcap"