meta-ampere: fwupdate: detect Host FW to flash

Support a wrapper script to detect the Host firmware image by checking
the ExtendedVersion field from the MANIFEST file to flash into
the appropriate device components. The supported image type include:
- ExtendedVersion=secondary: flash to secondary Host SPI-NOR
- ExtendedVersion=scp-primary: flash to primary Boot EEPROM
- ExtendedVersion=scp-secondary: flash to alternative Boot EEPROM
- ExtendedVersion=fru: write to the FRU EEPROM.

Tested:
1. Flash UEFI firmware into the primary Host SPI-NOR via WebUI
2. Flash UEFI firmware into the secondary Host SPI-NOR via WebUI

Signed-off-by: Chanh Nguyen <chanh@os.amperecomputing.com>
Change-Id: I7dff2ca0f8b9de85c2cbac1a49d04b6e14721a03
diff --git a/meta-ampere/meta-common/recipes-ac01/packagegroups/packagegroup-ampere-apps.bb b/meta-ampere/meta-common/recipes-ac01/packagegroups/packagegroup-ampere-apps.bb
index 856d3dc..9e32386 100644
--- a/meta-ampere/meta-common/recipes-ac01/packagegroups/packagegroup-ampere-apps.bb
+++ b/meta-ampere/meta-common/recipes-ac01/packagegroups/packagegroup-ampere-apps.bb
@@ -36,4 +36,5 @@
 SUMMARY:${PN}-flash = "Ampere Flash"
 RDEPENDS:${PN}-flash = " \
         ampere-flash-utils \
+        phosphor-software-manager \
         "