meta-security: subtree update:3001c3ebfc..b72cc7f87c

Armin Kuster (10):
      apparmor: add distro check
      smack: add distro check
      python-fail2ban: Drop python2 package
      python3-fail2ban: include python-fail2ban.inc
      google-authenticator-libpam: update to 1.07
      smack-test: add feature check for smack
      lib/oeqa/runtime: fix clamav test order
      clamav: update to 0.101.5
      meta-integrity: fix issues with yocto-check-layer
      fail2ban: fix runtime error

Change-Id: I4f7e656b0f9e2e9dc32989a1756c94e4e0143c42
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-security/recipes-mac/smack/smack_1.3.1.bb b/meta-security/recipes-mac/smack/smack_1.3.1.bb
index f32d91b..b1ea4e9 100644
--- a/meta-security/recipes-mac/smack/smack_1.3.1.bb
+++ b/meta-security/recipes-mac/smack/smack_1.3.1.bb
@@ -13,7 +13,12 @@
 
 PV = "1.3.1"
 
-inherit autotools update-rc.d pkgconfig ptest ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)}
+inherit autotools update-rc.d pkgconfig ptest
+inherit ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)}
+inherit features_check
+
+REQUIRED_DISTRO_FEATURES = "smack"
+
 
 S = "${WORKDIR}/git"