wspoon: Add service to help start MAX31785 hwmon

This service will be started in the udev rule for the MAX31785
hotplug add event.  It will wait for the phosphor-cooling-type
service to be done, and then run the script to start the
phosphor-hwmon instance for the MAX31785 fan controller after it
chooses the correct config file to use.

Tested: Test that this service correctly runs the script and that
        phosphor-hwmon does get started.

Change-Id: I4495f7073d63004d4dd8333df8964d69beaae4ea
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
index 16c8d61..7a83bf0 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
@@ -33,6 +33,8 @@
 SYSTEMD_ENVIRONMENT_FILE_max31785-msl += "obmc/hwmon-max31785/wspoon.conf"
 SYSTEMD_LINK_max31785-msl += "../phosphor-max31785-msl@.service:${SYSTEMD_DEFAULT_TARGET}.wants/phosphor-max31785-msl@wspoon.service"
 
+SYSTEMD_SERVICE_${PN} += "max31785-hwmon-helper@.service"
+
 do_install_append() {
     install -d ${D}${bindir}
     install -m 0755 ${WORKDIR}/start_max31785_hwmon.sh ${D}${bindir}