meta-amd: FPGA Register Dump Utility Script

Usage: fpgardu.sh
Uses i2c bus 2 to access FPGA registers and display the data

Signed-off-by: Paul Erb <paul.erb@amd.com>
Signed-off-by: Supreeth Venkatesh <supreeth.venkatesh@amd.com>
Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com>
Change-Id: I2608eb48fa4cb3ef2d8837bc22a8efe3dc339d37
diff --git a/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb b/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
new file mode 100644
index 0000000..3fcaeaa
--- /dev/null
+++ b/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
@@ -0,0 +1,18 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+SUMMARY = "AMD Ethanolx FPGA Register Dump Utility"
+DESCRIPTION = "AMD Ethanolx FPGA Register Dump Utility"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5e24678b8d0883d9dfa9e9473069ddd2"
+
+RDEPENDS_${PN} = "bash"
+SRCREV = "${AUTOREV}"
+SRC_URI =  "file://fpgardu.sh"
+SRC_URI += "file://LICENSE"
+
+S = "${WORKDIR}/"
+
+do_install () {
+        install -d ${D}${bindir}
+        install -m 0755 ${S}/fpgardu.sh ${D}${bindir}/
+}