meta-raspberrypi: subtree update:8cffbf5e85..ffc402ef5e

Andrei Gherzan (1):
      layer.conf: Define LAYERDEPENDS

Changqing Li (1):
      99-com.rules: fix error invalid substitution type

Khem Raj (2):
      linux-firmware-rpidistro: Update to 20190114-1+rpt11
      bluez-firmware-rpidistro: Update to 1.2-4+rpt8

Martin Jansa (3):
      linux-raspberrypi: allow to change the yocto-kernel-cache branch with LINUX_RPI_KMETA_BRANCH
      linux-raspberrypi-dev: drop protocol=git and add LINUX_RPI_KMETA_BRANCH
      linux-raspberrypi-dev: use static SRCREV when not selected with PREFERRED_PROVIDER_virtual/kernel

Pierre-Jean Texier (1):
      rpi-base: make SPLASH overridable from outside

SCVready (1):
      rpi-config: comment updated

matt-hammond-bbc (1):
      libva: Fix for when using `userland`

sss22213 (1):
      recipes-bsp: Add support for Raspberry Pi HD quality camera

Change-Id: I631fa1d4c12b9f91d5044712b6c2e712fcebd98b
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index de43c4b..052206a 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -118,10 +118,15 @@
 
     # Video camera support
     if [ "${VIDEO_CAMERA}" = "1" ]; then
-        # TODO: It has been observed that Raspberry Pi 4B 4GB may fail to enable the camera if "start_x=1" is at the end
-        #       of the file. The underlying cause is unknown, but it can be related with a file size limitation affecting
-        #       this variable. Therefore, "start_x=1" has been set to replace the original occurrence in config.txt,
-        #       which is at the middle of the file.
+        #   It has been observed that Raspberry Pi 4B 4GB may fail to enable the
+        # camera if "start_x=1" is at the end of the file. Therefore,
+        # "start_x=1" has been set to replace the original occurrence in
+        # config.txt, which is at the middle of the file.
+        #   The exact underlying cause is unknown. There are similar issues
+        # reported in the raspberrypi/firware repo and the conclusion reached
+        # was that there could be a file size limitation affecting certain
+        # variables. It was commented that this limitation could be 4k but
+        # not proved.
         sed -i '/#start_x=/ c\start_x=1' $CONFIG
     fi
 
@@ -184,10 +189,16 @@
 
     # Choose Camera Sensor to be used, default imx219 sensor
     if [ "${RASPBERRYPI_CAMERA_V2}" = "1" ]; then
-        echo "# Enable Sony RaspberryPi Camera" >> $CONFIG
+        echo "# Enable Sony RaspberryPi Camera(imx219)" >> $CONFIG
         echo "dtoverlay=imx219" >> $CONFIG
     fi
 
+    # Choose Camera Sensor to be used, default imx477 sensor
+    #if [ "${RASPBERRYPI_HD_CAMERA}" = "1" ]; then
+    #    echo "# Enable Sony RaspberryPi Camera(imx477)" >> $CONFIG
+    #    echo "dtoverlay=imx477" >> $CONFIG
+    #fi
+
     # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
     if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then
         echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> $CONFIG