meta-fii: meta-mori: Remove dependency for mori bios verify

The dependency obmc-host-reboot target has on obmc-host-shutdown and
phosphor-reboot-host must be removed to allow for the mori-bios-verify
service. The mori-bios-verify service will have a 60s sleep that
requires the host to hold its state for the 60s duration after it is
commanded to powercycle. Without these dependencies removed, the host
would shutdown immediately.

Signed-off-by: Jonico Eustaquio <jonico.eustaquio@fii-na.com>
Change-Id: If2df43c8276626a3623bd4e796d87ea6817c32c7
diff --git a/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 03510cf..ce1fae3 100644
--- a/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -14,6 +14,12 @@
     ln -s $TARGET $LINK
 }
 
+pkg_postinst:${PN}-obmc-targets:append:mori() {
+    rm "$D$systemd_system_unitdir/obmc-host-reboot@0.target.requires/obmc-host-shutdown@0.target"
+    rm "$D$systemd_system_unitdir/obmc-host-reboot@0.target.requires/phosphor-reboot-host@0.service"
+}
+
+
 pkg_prerm:${PN}-obmc-targets:prepend:mori() {
     LINK="$D$systemd_system_unitdir/multi-user.target.requires/phosphor-host-condition-gpio@0.service"
     rm $LINK