obmc-console: Rely on packaged systemd units

systemd units are now provided by obmc-console, so remove the in-tree
files.

(From meta-phosphor rev: 6e0e25f18aaf9e6d10e82b026e7e61bd08f418b5)

Change-Id: I22197d78acb39896dcc1ab87adb7f4778e1c84ec
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
index 7d11bff..baa7c8c 100644
--- a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
@@ -5,36 +5,57 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
 
-inherit obmc-phosphor-systemd
 inherit autotools pkgconfig
 inherit obmc-phosphor-discovery-service
+inherit systemd
 
-TARGET_CFLAGS   += "-fpic -O2"
+S = "${WORKDIR}/git"
+
+TARGET_CFLAGS += "-fpic -O2"
+
+PACKAGECONFIG ??= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[udev] = "--with-udevdir=`pkg-config --variable=udevdir udev`,\
+                       --without-udevdir,udev"
+PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, \
+                          --without-systemdsystemunitdir"
 
 DEPENDS += "autoconf-archive-native \
             systemd \
-            "
+           "
 
 SRC_URI += "git://github.com/openbmc/obmc-console"
 SRC_URI += "file://${BPN}.conf"
 
-SRCREV = "c5ce2cbd12e395749c3b4abedf0d81f49b402b70"
+SRCREV = "fdf1a7102f800711daadfc3895fc8feeffa73c0e"
 PV = "1.0+git${SRCPV}"
 
 REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200:"
-OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
-SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh@.service"
-SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh.socket"
 
-SYSTEMD_SERVICE_${PN} = " \
-        ${PN}@.service \
-        ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
-        ${PN}-ssh.socket \
-        ${PN}-ssh@.service \
-        "
+SYSTEMD_SERVICE_${PN} += "obmc-console-ssh@.service \
+                obmc-console-ssh.socket \
+                obmc-console@.service \
+                "
+
+FILES_${PN} += "/lib/systemd/system/obmc-console-ssh@.service.d/use-socket.conf"
+
 do_install_append() {
-        install -m 0755 -d ${D}${sysconfdir}
-        install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
+        # Install the server configuration
+        install -m 0755 -d ${D}${sysconfdir}/${BPN}
+        if test -f "${WORKDIR}/${BPN}.conf"; then
+                # Remove the upstream-provided server configuration
+                rm -f ${D}${sysconfdir}/${BPN}/server.ttyVUART0.conf
+                # Install the old-style server configuration
+                install -m 0644 ${WORKDIR}/${BPN}.conf ${D}${sysconfdir}/
+                # Link the custom configuration to the required location
+                ln -sr ${D}${sysconfdir}/${BPN}.conf ${D}${sysconfdir}/${BPN}/server.ttyVUART0.conf
+        elif test -f "${WORKDIR}/server.ttyVUART0.conf" ; then
+                # Remove the upstream-provided server configuration
+                rm -f ${D}${sysconfdir}/${BPN}/server.ttyVUART0.conf
+                # Install the package-provided new-style configuration
+                install -m 0644 ${WORKDIR}/server.ttyVUART0.conf ${D}${sysconfdir}/${BPN}/
+        else
+                # Otherwise, remove socket-id from the shipped configuration to
+                # align with the lack of a client configuration file
+                sed -ri '/^socket-id =/d' ${D}${sysconfdir}/${BPN}/server.ttyVUART0.conf
+        fi
 }
-
-S = "${WORKDIR}/git"