Variable to pass extra option to MRW parsers

This commit adds a variable to allow MRW parsers
to be passed an option to skip targets that are broken
or not fully defined in the MRW.

Recipes that invoke the parsers can use this option as
an indication to the parser script to ignore MRW errors.
The option variable is empty by default, but layers
can choose to override this as necessary.

Tested:
I tested by enabling this option in the meta-ibm rainier
layer and verified that the right option is passed to
the MRW parsers.

(From meta-phosphor rev: fc77979764f7c8599a451f619630f8d7be2cc09b)

Signed-off-by: Santosh Puranik <santosh.puranik@in.ibm.com>
Change-Id: I54b349597b30deb77a98af0686a67e03befe2429
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/classes/mrw-xml.bbclass b/meta-phosphor/classes/mrw-xml.bbclass
index 5a9c773..8876de7 100644
--- a/meta-phosphor/classes/mrw-xml.bbclass
+++ b/meta-phosphor/classes/mrw-xml.bbclass
@@ -1,2 +1,4 @@
 MRW_XML ??= "${MACHINE}.xml"
 mrw_datadir = "${datadir}/obmc-mrw"
+SKIP_BROKEN_MRW ?= "0"
+EXTRA_MRW_SCRIPT_ARGS = "${@bb.utils.contains("SKIP_BROKEN_MRW", "0", "", "--skip-broken-mrw", d)}"