Use openpower-proc-control in bitbake

The executable built from this repository will now be
used in start_host@.service and vcs_workaround@.service
instead of the shell scripts that use pdbg to do FSI commands.

Change-Id: I8ef3075449b562d64295ae330bd2c150264a0607
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-vcs-workaround.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-vcs-workaround.bb
index b03e26c..53b84a6 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-vcs-workaround.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-vcs-workaround.bb
@@ -5,19 +5,10 @@
 inherit obmc-phosphor-systemd
 inherit obmc-phosphor-license
 
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-pdbg-host-control:"
-
-RDEPENDS_${PN} += "pdbg \
-                   virtual-p9-vcs-workaround"
+FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
+RDEPENDS_${PN} += "virtual-p9-vcs-workaround op-proc-control"
 
 S = "${WORKDIR}"
-SRC_URI += "file://vcs_workaround.sh"
-
-do_install() {
-        install -d ${D}${bindir}
-        install -m 0755 ${WORKDIR}/vcs_workaround.sh \
-                        ${D}${bindir}/vcs_workaround.sh
-}
 
 TMPL = "vcs_workaround@.service"
 INSTFMT = "vcs_workaround@{0}.service"
@@ -26,4 +17,3 @@
 
 SYSTEMD_SERVICE_${PN} += "${TMPL}"
 SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_SUBSTITUTIONS += "MACHINE:${MACHINE}:${TMPL}"