Add OBMC_IMAGE_EXTRA_INSTALL variable

Prior to this patch packagegroup-core-boot was not being pulled in.
core-boot is what brings in the init_manager (systemd) but
somehow systemd was added as a dependency by OE for the skeleton package
so the missing core-boot packagegroup went unnoticed.

core-boot was not being pulled in because of an assignment to
IMAGE_INSTALL in the global configuration.  Yocto core provides a
mechanism to do the same thing safely - CORE_IMAGE_EXTRA_INSTALL;
use this and also adopt a similar approach for adding extra packages
to image recipes using obmc-phosphor-image.

Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index ce54777..c715ded 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -36,15 +36,17 @@
         ssh-server-dropbear \
         "
 
-IMAGE_INSTALL += " \
-        bash \
+CORE_IMAGE_EXTRA_INSTALL_append = " bash \
         packagegroup-obmc-phosphor-apps-extras \
         i2c-tools \
         screen \
         inarp \
         obmc-console \
+        ${OBMC_IMAGE_EXTRA_INSTALL} \
         "
 
+OBMC_IMAGE_EXTRA_INSTALL ?= ""
+
 def build_overlay(d):
         if bb.utils.contains("IMAGE_FSTYPES", "overlay", "overlay", "0", d) != "0":
                 return "image-overlay"