meson: move phosphor-state-manager to meson

Includes the following in bump:

Andrew Geissler (9):
      meson: fix up compile errors found by meson
      meson: binary building support
      meson: fix new warnings found by clang-tidy
      meson: enable unit tests
      meson: move service file into its own subdir
      meson: add in service file support
      meson: add json file into meson
      meson: add obmcutil to bindir
      meson: remove automake legacy files

(From meta-phosphor rev: c1debbbad981bae1ecfdaa41da4d5ac68f3f9173)

Change-Id: Ic9ff5ced2b8fefa4830fac6005b5af855e6d06c8
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index 137dcee..2f3ceb6 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -35,10 +35,9 @@
 # recommended to deal properly with these reset scenarios.
 RRECOMMENDS_${PN}-host = "${PN}-host-check ${PN}-reset-sensor-states"
 
-inherit autotools pkgconfig
+inherit meson pkgconfig
 inherit obmc-phosphor-dbus-service
 
-DEPENDS += "autoconf-archive-native"
 DEPENDS += "sdbusplus"
 DEPENDS += "sdeventplus"
 DEPENDS += "phosphor-logging"
@@ -143,10 +142,10 @@
 
 do_install_append() {
   install -d ${D}${sysconfdir}/phosphor-systemd-target-monitor
-  install ${S}/phosphor-target-monitor-default.json ${D}${sysconfdir}/phosphor-systemd-target-monitor/phosphor-target-monitor-default.json
+  install ${S}/data/phosphor-target-monitor-default.json ${D}${sysconfdir}/phosphor-systemd-target-monitor/phosphor-target-monitor-default.json
 }
 
 SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
-SRCREV = "c543af24b4537aafa85482994f27539afe4a6590"
+SRCREV = "4640d48e998709f1b64b97347db0f1b355b7f423"
 
 S = "${WORKDIR}/git"