meta-aspeed: Consolidate u-boot fw_env configuration

The 32MB and 64MB NOR environments are the same configuration, so use
the one file.

The AST2600 NOR layout is the same size as the others so it can use the
same file too.

Change-Id: I6ee3fbf0d68104bcc684c2536fe85c5aec76c409
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 1a7e8f5..e02369f 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -8,16 +8,12 @@
 PROVIDES += "u-boot-fw-utils"
 RPROVIDES:${PN} += "u-boot-fw-utils"
 
-SRC_URI += "file://fw_env_ast2600_nor.config"
+# The 32MB NOR and 64MB NOR layouts use the same configuration
+SRC_URI += "file://fw_env_flash_nor.config"
 SRC_URI += "file://fw_env_ast2600_mmc.config"
-SRC_URI += "file://fw_env_flash_32M_nor.config"
-SRC_URI += "file://fw_env_flash_64M_nor.config"
-SRC_URI:append:uboot-flash-32768 = " file://u-boot_flash_32M.cfg"
 
-ENV_CONFIG_FILE = "fw_env_ast2600_nor.config"
+ENV_CONFIG_FILE = "fw_env_flash_nor.config"
 ENV_CONFIG_FILE:df-phosphor-mmc = "fw_env_ast2600_mmc.config"
-ENV_CONFIG_FILE:uboot-flash-32768 = "fw_env_flash_32M_nor.config"
-ENV_CONFIG_FILE:uboot-flash-65536 = "fw_env_flash_64M_nor.config"
 
 INSANE_SKIP:${PN} = "already-stripped"
 EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'