u-boot-aspeed-sdk: use u-boot do_configure for fw-utils

Previously, the u-boot-fw-utils-aspeed-sdk build didn't take *.cfg files
in SRC_URI into account at all, leading to problematic mismatches
between fw_{set,print}env's configuration and that of u-boot itself
(such as discrepancies in their respective notions of what the default
environment should be).

With this change the fw-utils build uses the same do_configure as the
regular u-boot build, so the two packages can more easily be built with
a single consistent configuration.

Signed-off-by: Zev Weiss <zev@bewilderbeest.net>
Change-Id: Ia83768597b6b75dc00425bdc23f216274d87e0ae
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 2708ae0..22976ef 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -1,5 +1,6 @@
 require u-boot-common-aspeed-sdk_${PV}.inc
 require conf/machine/distro/include/uboot-distrovars.inc
+require recipes-bsp/u-boot/u-boot-configure.inc
 
 SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
 DEPENDS += "mtd-utils"
@@ -22,7 +23,6 @@
 inherit uboot-config
 
 do_compile () {
-	oe_runmake -C ${S} O=${B} ${UBOOT_MACHINE}
 	oe_runmake envtools
 }