meta-ibm: Tacoma uses witherspoon machine's JSON configs

The `witherspoon-tacoma` machine utilizes the same JSON config files as
the `witherspoon` machine so override the PKG_DEFAULT_MACHINE variable
for tacoma to be set to the witherspoon machine name "witherspoon". This
will then install the witherspoon machine JSON config files into the
tacoma image.

Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Change-Id: I6ce40547ebe536ca149930c439b0ee21d66061fb
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
index f9b2613..a6d0357 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -67,3 +67,7 @@
 # file that's used for witherspoon type(including witherspoon-tacoma) machines
 SYSTEMD_SUBSTITUTIONS:witherspoon = "ADDR:100:phosphor-fan-control@.service"
 SYSTEMD_SUBSTITUTIONS:witherspoon-tacoma = "ADDR:200:phosphor-fan-control@.service"
+
+# Set the PKG_DEFAULT_MACHINE name to "witherspoon" for tacoma so witherspoon's
+# JSON config files are installed on tacoma machines (since they use the same ones)
+PKG_DEFAULT_MACHINE:witherspoon-tacoma = "witherspoon"