hypervisor: introduce new package for state manager

This new phosphor-state-manager package allows a user to track the state
of their hypervisor firmware. This new software utilizes the
BootProgress property to determine the hypervisor state and relies on a
different software entity (for example PLDM) to monitor state requests
and send the appropriate messages to the hypervisor firmware.

Includes the autobump which has the new function:

phosphor-state-manager: srcrev bump 58477b5287..75f38ee42d

Andrew Geissler (3):
      hypervisor: state management support
      hypervisor: monitor boot progress
      hypervisor: reset requested host state on power off

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I4c4bfc06db3b38b114c28692db808cffceff628a
diff --git a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 075cdda..4720112 100644
--- a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -4,3 +4,8 @@
 # schedule power on and off operations for the host at some
 # time in the future. IBM systems will utilize this feature
 RRECOMMENDS_${PN}-host += "${PN}-scheduled-host-transition"
+
+# IBM systems track the state of the hypervisor so bring
+# in the needed package when the host state package is
+# included
+RRECOMMENDS_${PN}-host += "${PN}-hypervisor"