meta-google: conf2struct-native: Add package

Google-Bug-Id: 179618161
Upstream: 8ac594bdf054082ca6dbe35c4345759fe4c31669
Change-Id: I1f86406891528241295455c6498f2a488d5b1b78
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb b/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
new file mode 100644
index 0000000..1a77f4d
--- /dev/null
+++ b/meta-google/recipes-extended/libconfig/conf2struct-native_git.bb
@@ -0,0 +1,32 @@
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1b886630cdc9a17c26250934beda407d"
+
+PV = "0.1+git${SRCPV}"
+SRC_URI = "git://github.com/yrutschle/conf2struct"
+SRCREV = "e8468017b27211b1c452f8df0afe6f19e97035a4"
+S = "${WORKDIR}/git"
+
+SRC_URI += " \
+  file://0001-makefile-Add-missing-LDFLAGS.patch \
+  file://0001-conf2struct-Use-the-right-perl.patch \
+  "
+
+inherit native
+
+DEPENDS += " \
+  libconfig-native \
+  libconfig-perl-native \
+  "
+
+EXTRA_OEMAKE += " \
+  DESTDIR=${D} \
+  prefix=${prefix} \
+  "
+
+do_compile() {
+    oe_runmake checker
+}
+
+do_install() {
+    oe_runmake install
+}