quanta-q71l package for controlling the SPI master.

Testing: Used this version to change the register during a BIOS
flashing, and it worked as expected.

Change-Id: I13e59f6917d535647679cc84ff5c62ed1602ad4d
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/meta-openbmc-machines/meta-x86/meta-quanta/meta-q71l/recipes-phosphor/spictrl/spictrl.bb b/meta-openbmc-machines/meta-x86/meta-quanta/meta-q71l/recipes-phosphor/spictrl/spictrl.bb
new file mode 100644
index 0000000..5b2fcf2
--- /dev/null
+++ b/meta-openbmc-machines/meta-x86/meta-quanta/meta-q71l/recipes-phosphor/spictrl/spictrl.bb
@@ -0,0 +1,19 @@
+# Should RDEPENDS on python at the very least.
+FILESEXTRAPATHS_append := "${THISDIR}/files:"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://spimaster.py;beginline=1;endline=13;md5=b86c59990b35609be34a0ec322a3cfff"
+
+S = "${WORKDIR}/"
+
+SRC_URI = "file://spimaster.py"
+
+DEPENDS = "python"
+
+FILES_${PN} += "*"
+
+do_install() {
+    install -d ${D}/home
+    install -d ${D}/home/root
+    install -m 0755 ${S}/spimaster.py ${D}/home/root/.
+}