Squashed 'import-layers/meta-openembedded/' content from commit 247b126

Change-Id: I40827e9ce5fba63f1cca2a0be44976ae8383b4c0
git-subtree-dir: import-layers/meta-openembedded
git-subtree-split: 247b1267bbe95719cd4877d2d3cfbaf2a2f4865a
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/import-layers/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.18.0.bb b/import-layers/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.18.0.bb
new file mode 100644
index 0000000..2b6f15e
--- /dev/null
+++ b/import-layers/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.18.0.bb
@@ -0,0 +1,29 @@
+SUMMARY = "configuation database system"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+SECTION = "x11/gnome"
+
+inherit gnomebase gsettings
+SRC_URI[archive.md5sum] = "69a12ed68893f2e1e81ac4e531bc1515"
+SRC_URI[archive.sha256sum] = "109b1bc6078690af1ed88cb144ef5c5aee7304769d8bdc82ed48c3696f10c955"
+GNOME_COMPRESS_TYPE = "xz"
+
+DEPENDS = "glib-2.0 gtk+3 libxml2"
+
+inherit vala gtk-doc
+
+EXTRA_OECONF += "--disable-man"
+
+PACKAGES =+ "dconf-editor"
+
+FILES_${PN} += " \
+	${datadir}/dbus-1 \
+	${libdir}/gio/modules/*.so \
+"
+FILES_dconf-editor = " \
+	${bindir}/dconf-editor \
+	${datadir}/icons \
+	${datadir}/bash-completion \
+"
+FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/libdconfsettings.so"