move generic chassis services into phosphor-state-manager

Move the generic services which are used to power on and off the chassis
into phosphor-state-manager. This will make the use of
phosphor-state-manager for chassis power control more straightforward.

The following email has more details on this change:
  https://lists.ozlabs.org/pipermail/openbmc/2022-November/032457.html

phosphor-state-manager: srcrev bump eab2ea348d..69a250dd45

Andrew Geissler (2):
      move chassis power services to phosphor-state-manager
      improve new chassis power services

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I14fce315107cafacb0500d8664e51d9f61f7864d
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index f6b7a76..0b99361 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -74,6 +74,11 @@
 
 FILES:${PN}-chassis = "${bindir}/phosphor-chassis-state-manager"
 DBUS_SERVICE:${PN}-chassis += "xyz.openbmc_project.State.Chassis@.service"
+SYSTEMD_SERVICE:${PN}-chassis += "obmc-power-start@.service"
+SYSTEMD_SERVICE:${PN}-chassis += "obmc-power-stop@.service"
+SYSTEMD_SERVICE:${PN}-chassis += "obmc-powered-off@.service"
+SYSTEMD_SERVICE:${PN}-chassis += "phosphor-reset-chassis-on@.service"
+SYSTEMD_SERVICE:${PN}-chassis += "phosphor-reset-chassis-running@.service"
 
 FILES:${PN}-chassis += "${bindir}/obmcutil"
 
@@ -201,6 +206,6 @@
 
 
 SRC_URI += "git://github.com/openbmc/phosphor-state-manager;branch=master;protocol=https"
-SRCREV = "eab2ea348d0a2a1b444b6a2c3c4814f277db9870"
+SRCREV = "69a250dd4504c53449bb5136435fddbc168edd1c"
 
 S = "${WORKDIR}/git"