u-boot-aspeed: improve env handling

This fixes some build errors we faced due to add new ast2500-based
platform.
* Allow to redefine input env file.
* Backport providing "u-boot-default-env" from u-boot.inc
* PROVIDES += "u-boot-fw-utils" is not enough, add also RPROVIDES

Last two changes allows to exclude from build modern libubootenv which
somewhy doesn't work for us.

Signed-off-by: Andrei Kartashev <a.kartashev@yadro.com>
Change-Id: I33f152c572f6c0b4d8b608375b252290efacd1ea
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 13a4081..6c1470a 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -4,6 +4,7 @@
 DEPENDS += "mtd-utils"
 
 PROVIDES += "u-boot-fw-utils"
+RPROVIDES:${PN} += "u-boot-fw-utils"
 
 SRC_URI += "file://fw_env_ast2600_nor.config"
 SRC_URI += "file://fw_env_ast2600_mmc.config"