dropbear: Copy localoptions.h to build directory

Per the dropbear documentation, the localoptions.h file needs to be
copied to its build directory to take effect.

This file can later be renamed to src/distrooptions.h once the following
dropbear change is merged:
https://github.com/mkj/dropbear/pull/274

Tested:

Before change:
$ ssh -vv p10bmc
...
debug2: MACs ctos: hmac-sha1,hmac-sha2-256
debug2: MACs stoc: hmac-sha1,hmac-sha2-256

After change:
$ ssh -vv p10bmc
...
debug2: MACs ctos: hmac-sha1,hmac-sha2-256,hmac-sha2-512
debug2: MACs stoc: hmac-sha1,hmac-sha2-256,hmac-sha2-512

Change-Id: I1a4b108d1a87831f4623c7e3e1e2beb0b8655441
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-phosphor/recipes-core/dropbear/dropbear_%.bbappend b/meta-phosphor/recipes-core/dropbear/dropbear_%.bbappend
index 6448fbf..cc7e56c 100644
--- a/meta-phosphor/recipes-core/dropbear/dropbear_%.bbappend
+++ b/meta-phosphor/recipes-core/dropbear/dropbear_%.bbappend
@@ -10,6 +10,10 @@
             file://migrate-key-location \
            "
 
+do_configure:append() {
+    install -m 0644 ${WORKDIR}/localoptions.h ${B}
+}
+
 # pull in OpenSSH's /usr/libexec/sftp-server so we don't have to rely
 # on the crufty old scp protocol for file transfer
 RDEPENDS:${PN} += "openssh-sftp-server"