meta-zaius: Modify recipe variables based on machine

In bbappend files, use the override style syntax to modify variables and
specify appends and prepends with the machine name. This limits the
scope of their effects to only when MACHINE=zaius.

This allows meta-zaius to be present in BBLAYERS without causing side
effects except when building for Zaius BMC.

Signed-off-by: Xo Wang <xow@google.com>
Change-Id: Iaccc5cb1abac033dab54411eaa20855172ad3283
diff --git a/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-kernel/linux/linux-obmc_%.bbappend b/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-kernel/linux/linux-obmc_%.bbappend
index 543bfe0..f3a8399 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-kernel/linux/linux-obmc_%.bbappend
+++ b/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-kernel/linux/linux-obmc_%.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux-obmc:"
-SRC_URI += "file://zaius.cfg"
+FILESEXTRAPATHS_prepend_zaius := "${THISDIR}/${PN}:"
+SRC_URI_append_zaius = " file://zaius.cfg"