meta-phosphor: add vardeps for HOST and CHASSIS instances

If a system were to change the OBMC_HOST_INSTANCES or
OBMC_CHASSIS_INSTANCES, many packages (incorrectly) do not get rebuilt.
This is because the variables are evaluated within Python contexts and
are not manually specified in the `vardeps`.  Add as necessary.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I84651a1a85a5c977be674d8b26b6e43e5ab46850
diff --git a/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb b/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
index 1912c57..e691623 100644
--- a/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/phosphor-skeleton-control-power_git.bb
@@ -16,6 +16,7 @@
 OBMC_CONTROL_SVC = "org.openbmc.control.Power@.service"
 OBMC_CONTROL_FMT = "../${OBMC_CONTROL_SVC}:multi-user.target.wants/${OBMC_CONTROL_INST}"
 SYSTEMD_LINK:${PN} += "${@compose_list(d, 'OBMC_CONTROL_FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK[vardeps] += "OBMC_CHASSIS_INSTANCES"
 
 SYSTEMD_SERVICE:${PN} += " \
         phosphor-wait-power-on@.service \