meta-phosphor: add vardeps for HOST and CHASSIS instances

If a system were to change the OBMC_HOST_INSTANCES or
OBMC_CHASSIS_INSTANCES, many packages (incorrectly) do not get rebuilt.
This is because the variables are evaluated within Python contexts and
are not manually specified in the `vardeps`.  Add as necessary.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I84651a1a85a5c977be674d8b26b6e43e5ab46850
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index aeb40fe..7a5bd24 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -116,6 +116,7 @@
 SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
 SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
 SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK[vardeps] += "OBMC_HOST_INSTANCES"
 
 #Collect all hardcoded sensor yamls from different recipes and
 #merge all of them with sensor.yaml.