meta-phosphor: add vardeps for HOST and CHASSIS instances

If a system were to change the OBMC_HOST_INSTANCES or
OBMC_CHASSIS_INSTANCES, many packages (incorrectly) do not get rebuilt.
This is because the variables are evaluated within Python contexts and
are not manually specified in the `vardeps`.  Add as necessary.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I84651a1a85a5c977be674d8b26b6e43e5ab46850
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index b5f5050..1d4387b 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -259,6 +259,7 @@
 RESET_INSTFMT_CTRL = "obmc-chassis-powerreset@{0}.target"
 RESET_FMT_CTRL = "../${RESET_TMPL_CTRL}:${SYSD_TGT}.wants/${RESET_INSTFMT_CTRL}"
 SYSTEMD_LINK:${PN}-obmc-targets += "${@compose_list_zip(d, 'RESET_FMT_CTRL', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK[vardeps] += "OBMC_CHASSIS_INSTANCES OBMC_HOST_INSTANCES"
 
 SRC_URI = "git://github.com/openbmc/phosphor-state-manager;branch=master;protocol=https"
 SRCREV = "8be7ec4510d7932dd9a8942cfa67cc05fe10866f"