meta-phosphor: add vardeps for HOST and CHASSIS instances

If a system were to change the OBMC_HOST_INSTANCES or
OBMC_CHASSIS_INSTANCES, many packages (incorrectly) do not get rebuilt.
This is because the variables are evaluated within Python contexts and
are not manually specified in the `vardeps`.  Add as necessary.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I84651a1a85a5c977be674d8b26b6e43e5ab46850
diff --git a/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb b/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
index c39fca4..ebc9d4f 100644
--- a/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
+++ b/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
@@ -50,3 +50,4 @@
 
 SYSTEMD_LINK:${PN} += "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}"
 SYSTEMD_LINK:${PN} += "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK[vardeps] += "OBMC_HOST_INSTANCES OBMC_HOST_WATCHDOG_INSTANCES"