Add in OCC hwmon config file

OCC hwmon sensor support is more complicated then other hwmon
sensors.  It requires that software look at the label and
include that in the generated dbus sensor.  A separate
commit in phosphor-hwmon will handle this new function.

The hwmon conf file indicates this new functionial requirement
to hwmon by including a new MODE_*=label for each sensor
that requires this function.

Resolves openbmc/openbmc#1183

Change-Id: I55bff27d3eab478559ae42e290dfe74e2f627e12
Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
index 635fbcd..6ee00c0 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
@@ -8,10 +8,16 @@
                i2c@1e78a000/i2c-bus@180/ir35221@70 \
                i2c@1e78a000/i2c-bus@180/ir35221@71 \
                "
-
 WSPOON_ITEMSFMT = "ahb/apb/{0}.conf"
-
 WSPOON_ITEMS = "${@compose_list(d, 'WSPOON_ITEMSFMT', 'WSPOON_CHIPS')}"
 
+WSPOON_OCCS = " \
+              cfam@0,0/sbefifo@2400/occ@1 \
+              cfam@0,0/sbefifo@82400/occ@2 \
+              "
+WSPOON_OCCSFMT = "base/gpio-fsi/{0}.conf"
+WSPOON_OCCITEMS = "${@compose_list(d, 'WSPOON_OCCSFMT', 'WSPOON_OCCS')}"
+
 ENVS = "obmc/hwmon/{0}"
 SYSTEMD_ENVIRONMENT_FILE_${PN} += "${@compose_list(d, 'ENVS', 'WSPOON_ITEMS')}"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "${@compose_list(d, 'ENVS', 'WSPOON_OCCITEMS')}"