meta-ibm: p10bmc: Add machine U-Boot configuration fragment

Configure U-Boot for p10bmc machines to enable the "AST2600 IBM" board
and disable conflicting options.

Follow the pattern used by the Qualcomm layer of putting the snippet in
files, which has the added bonus of saving a level of directory nesting.

Signed-off-by: Eddie James <eajames@linux.ibm.com>
Change-Id: I30a2822b65c5ff826f9f5b3fa71bcec9d402c74c
diff --git a/meta-ibm/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bbappend b/meta-ibm/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bbappend
index b805587..b752dd5 100644
--- a/meta-ibm/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bbappend
+++ b/meta-ibm/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bbappend
@@ -1,6 +1,8 @@
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
 
 SRC_URI:append:p10bmc = " file://ibm.json file://ips.json file://keys/"
+SRC_URI:append:p10bmc = " file://p10bmc.cfg"
 
 OTPTOOL_CONFIGS:p10bmc = "${WORKDIR}/ibm.json ${WORKDIR}/ips.json"
 OTPTOOL_KEY_DIR:p10bmc = "${WORKDIR}/keys/"